EE 331 Digital Systems with HDL
Oregon Tech, Wilsonville, Winter 2014

Lab (Homework) Assignment, due Week 3 (January 21)

Before starting the assignment you must install the software as described in the
document Software_lInstallation.pdf. This should be completed either during the
first class session or by the second session so if you have any problems they can be
resolved before the due date of the lab.

The Nexys board has 8 slide switches and 8 LEDs connected to the Xilinx FPGA. You
are to create the logic for the FPGA and assign the FPGA pins so that if the right-
most two switches are turned on the right-most LED will be turned on, otherwise it
will be off. The process is to be repeated for each pair of switches up to if the left-
most two switches are on the seventh LED will be turned on. Finally, if the left- and
right-most switches are on the left-most LED will be turned on. Based on the
labeling in the schematic, we can say:

LDO is on if and only if SWO and SW1 are both on.

LD1is on if and only if SW1 and SW2 are both on.

LD2 is on if and only if SW2 and SW3 are both on.

LD3 is on if and only if SW3 and SW4 are both on.

LD4 is on if and only if SW4 and SW5 are both on.

LDS is on if and only if SW5 and SW6 are both on.

LD6 is on if and only if SW6 and SW7 are both on.

LD7 is on if and only if SW7 and SWO are both on.

This assignment has three parts. In the first part you will create a project for the
assignment and simulate operation using the provided test bench. In the second
part you will synthesize the working design from the first part and execute it on your
Nexys board. In the third part you will use PlanAhead to do the FPGA pin
assignments.

Part 1 — Simulation
Start the Xilinx ISE program and create a new project (File->New Project...). The

project name and path should contain no space characters. Make sure the Top-level
source type is “HDL".
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Create New Project

Specify project location and type.

Enter a name, locations, and comment for the project

Name: |Lab1 |
Location: |C:WilinxProjects\Lab1 | =)
Working Directory: | C:WiinxProjects\Lab1 |
Description:

Select the type of top-level source for the project

Top-evel source type:

[ net ||

Cancel

Click on “Next.” The Project Settings page should be set to look like the following:

Project Settings
Specdify device and project properties.
Select the device and design flow for the project
Property Name Value I
Product Category All =
Family | Spartanb v
Device XC6SLX16 v
Package |CSG324 v
Speed 3 B
0|
Top-Level Source Type HDL v
Synthesis Tool |XST (VHDL/Verilog) v
Simulator ISim (VHDL/Verilog) v
Preferred Language |VHDL lv|
Property Specification in Project File | Store all values |
Manual Compile Order
VHDL Source Analysis Standard |VHDL-93 v
VEI"»Ia_ble} Message Filtering ,
|
_ MoreInfo | | Next | | Cancel
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You should verify the settings for each project you make, although Xilinx ISE
remembers the last settings for new designs. Now click on “Next” and then
“Finished"”.

The design has no modules. Create a top-level module that will contain all the logic
for your design. Go to Project->New Source... select “VHDL Module” and give it a
name. Call it “top_level”. When you name your own modules you may use
underscores in the name but do not use any spaces.

[~ | Ei r
4

Ev New Source Wizard

Select Source Type

Select source type, file name and its location.
. IP (CORE Generator & Architecture Wizard)
Schematic
User Document
Verilog Module
Verilog Test Fixture
VHDL Module
VHDL Library
VHDL Package top_level
VHDL Test Bench
Embedded Processor

File name:

Location:

C:\XilinxProjects\Lab1

Add to project

][ Cancel J

When you click “Next” you will be given the opportunity to describe the ports
connecting the module to the outside, either the simulation or the FPGA pins.
Because the 8 switches and 8 LEDs are easily described as 8-wire busses, we will
describe them as busses. In the image below I've filled in the first line for the 8
switches. You will need to also add a line for the 8 LEDs, which are outputs and
must be named Led. Why “must?” Well, the connections have already been named
elsewhere for you, and the names must match just like the name of the module.

In this course we will standardize bit numbering with the least significant bit being
bit 0. To access sw0, we use sw(0). To access swl, we use sw(1), and so forth.
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3 C )

Define Module

Specify ports for module.
Entity name |top_level

Architecture name | Behavioral

Port Name Direction Bus MSB LSB =4
. R
in B [
in B [
in E [ 3
in B [
in B [
in B [l B
in E [
in B [
in =l >

When you finish the New Source Wizard you will have a top_level.vhd file
containing the skeleton for a module named top_level with the correct ports
already declared. You need to fill it in with the correct logic for the problem. With
the top_level module selected in the Hierarchy pane (upper left) you can use the
“Check Syntax” process under Synthesize-XST to check your design syntax before
proceeding to simulation.

A simulation test bench file has been provided for you to use. The file,

labl_test_bench.vhd is provided on the distribution. You need to add it to your
project using Project->Add Copy of Source... Associate the file with Simulation:
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k= Adding Source Files... &J

The following allows you to see the status of the source files being added to the project. It
also allows you to specify the Design View assodation, and for VHDL sources the library, for
sources which are successfully added to the project.

File Name ‘ Association I Library
1 @ 1abl_test_bench.vhd work E]

Adding files to project: | EEEE—E—_—_—E | 1 of 1 files (0 errors)

[ ok || concel || rep |

Go to the Simulation View and select the test bench:

Right click on the process “Simulate Behavioral Model” and
select “Process Properties...". Then change the Simulation
Run Time to 2700 ns. Then click on Simulate Behavioral
Model to run the simulation. You will get error messages if
the port or module names do not match. The Console area
at the bottom of the simulator window will indicate if your
design did not work properly. You can also pan and zoom
in the waveform display to observe operation. The test
bench tries every combination of switch inputs and verifies
that the LED are lighting properly.
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SRR

View: ©) {a}}lmplementaﬁon © [ simulation
Behavioral v

Hierarchy

& Labl

= £ xcbshd6-3csg324

[=8 [ labl_test bench - behavior (labl_t
g uut - top_level - Behavioral (to

D | F— »

€2 No Processes Running

Processes: labl_test_bench - behavior
-9  ISim Simulator
¥)  Behavioral Check Syntax
@8  Simulate Behavioral Model




£ ISim (M.81d) - [Default.wcfg]

[ File Edit View Simulation Window Layout Help
02 N Do o | % ) B H M
Instances and Processes 0 & X||Objects 08 x|
Simulation Objects for lab1_test_bench
Instance and Process Name Design Unit Blo g = - C » ?s sw7:0] 11111111
1} 1ab1_test_bench lab1_test_be.. VHD|| Object Name Value i ) R 11111111
@ std_logic 1164 std_logic 1164 VHD 25 sw[r:0] 11111111
¥ std_logic_arith std_logic_arith VHD ;s led[7:0] 11111111
1 clock_period 10000 ps

1§ dock_period 10000 ps

; g
& Instances and Processes | (2 Memory ||[E] Source Fies | | « i ) Default.wcfg [x]

Console <08 X
WARNING: Please use Xilinx License Configuration Manager to check out a full ISim license.

WARNING: ISim will run in Lite mode. Please refer to the ISim documentation for more information on the differences between the Lite and the Full version.

This is a Lite version of ISim.

Time resolution is 1ps

Simulator is doing dircuit initialization process.

Finished drcuit initialization process. -

@ Console | ® Breskpoints | g8 FindinFiesResults | [y SearchResuts

Sim Time: 2,700,000 ps

Part 2 — Synthesis

To synthesize the design we need to assign the signals to pins on the FPGA. This is
done using a “User Constraint File”. Digilent provides one for the Nexys 3 board
named Nexys3_Master.ucf which is provided with the course materials. You need to
add that file to the project, as was done for the test bench, this time specifying that
it is for the Implementation and not the Simulation. Locate the file in the hierarchy
pane and double-click to open the file. You need to uncomment (remove the
leading hash character) the lines that define the pins you are using. In this case it is
the Net lines for the Leds and the Switches. Save the file, select the top_Llevel file in
the hierarchy, and then right-click on Generate Programming File in Processes and
select Process Properties... Under Startup Options, change the FPGA Start-Up Clock
to JTAG Clock. Click OK.

Now double-click on Generate Program File and sit back as the design is
synthesized, placed, and routed for the FPGA.

When it says the process has completed successfully, attach the Nexys 3 board to
the computer. This will cause the installation of Digilent Adept to complete. Start
the Adept program. It should show that it was able to find the FPGA on the Nexys 3
board. Click on Browse and locate the file top_level.bit in the project folder. Click
on Program and your design should now be running on your Nexys 3 board!

Part 3 — Using the PlanAhead program for pin assignments

In this part you will use the PlanAhead program instead of the Nexys3_Master.ucf
file to do the pin assignments. First you will need to select the Nexys3_Master.ucf
file again, right-click and Remove from the project. You have just undone most of
your work for part 2!

Now with the top_level file selected in the hierarchy, click on the process under
User Constraints named “I/O Pin Planning (PlanAhead — Post-Synthesis).” When the
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program has started, enlarge the window on the upper left and select the pane titled
I/O Ports.

1 e e TR s At st 2 =

File Edit View Tools Window Select Layout Help

BowoXHPer BEOEREG M

Netlist Design - top_level.ucf (target) | xc6slx16csg324-3

1/O Ports - F a X

oz sEE

Name Dir Neg Diff Pair  Site  Bank  I/OStd Vcco  Vref  Drive Strength  Slew Type  Pull Type  Off-Chip Termination

=)= All ports (16

B-Q Led (8 Output LVCMOS25 2.500 12 SLOW FP_VTT_50
< Led[0] Output LVCMOS25 2.500 12 SLOwW FP_VTT_50
<J Led[1] Output LVCMOS25 2.500 12 SLOwW FP_VTT_S0
< Led[2] Output LVCMOS25 2.500 12 SLOwW FP_VTT_50
< Led[3] Output LVCMOS25 2.500 12 SLOW FP_VTT_50
< Led[4] Output LVCMOS25 2.500 12 SLOW FP_VTT_50
<J Led[5] Output LVCMOS25 2.500 12 sLow FP_VTT_50
<J Led[6] Output LVCMOS25 2.500 12 SLOW FP_VTT_S0
< Led[7] Output LVCMOS25 2.500 12 SLOW FP_VTT_S0
= sw (3 Input LVCMOS25 12 SLOW NONE

D swlo] Input LVCMOS25 12 SLOwW NONE
D swl1] Input LVCMOS25 12 SLOw NONE
D swl2] Input LVCMOS25 12 SLOwW NONE
D sw[3] Input LVCMOS25 12 SLOW NONE
D sw[4] Input LVCMOS25 12 SLOwW NONE
D sw[s5] Input LVCMOS25 12 SLow NONE
O swle] Input LVCMOS25 12 SLOwW NONE
D swl7] Input LVCMOS25 12 SLOW NONE
) Scalar ports (0

< 1 r 3

3 Netiist Physical Constraints | £, Timing Constraints | [O- I/O Ports | @i Clock Regions

This shows all the ports and will allow you to assign pins to each of them. Select the
row Led(8), and change the I/O Std to LVCMOS33. Press Enter and all the LED rows
will change. Do the same for the sw row. Now click on the site for Led[0] and type in
U16, the pin name for LDO. Repeat the process for all the LED and switch pins. You
can find the assignments in the Nexys 3 users manual, the silkscreen on the Nexys 3
itself, or the Nexys3_Master.ucf file! When you are done, close PlanAhead.

Repeat the synthesis process you did in part 2, and observe operation of the board.

To Turn In:

1. A couple of paragraphs discussing what you did, in a Word (or OpenOffice or
Pages or PDF) document.

2. The top level VHDL file, incorporated into the document. Make sure itis in
Courier or some other mono-spaced font.

3. Snapshot showing the simulation result (like | did in this assignment sheet).
Incorporate into the document.

4. Snapshot of the filled in PlanAhead screen, like the (not filled in) one above.
Incorporate into the document.

5. Design summary (for either part 2 or 3). To do this click on Design Summary
among the listed files, Make sure the Design Overview Summary is showing.
Right click and select “View Report as HTML". When the HTML summary appears,
do a File-->Save As and save the HTML file. It is not easy to incorporate this in a
document, but if you can manage, go ahead!
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